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CHAPTER 9 
Peer Group Manager

INTRODUCTION 
A peer group is a tool that allows you to define and save a list of entities and use that 
list to filter data. You can use peer groups in any of COALdat’s software 
components, in multiple data sets, and across any RDI database product.  

Using peer groups and the Peer Group Manager, you can create, edit, use, and save 
data specific to the entities included in your list. Peer groups can be stored in a 
network file so that multiple users can access saved groups.  

The Peer Group Manager can be accessed at any time by clicking the Peer Group 
Manager button on the main toolbar, or by using the View menu and selecting the 
Peer Group Manager option.  

The Peer Group Manager has three primary functions:  

• An organizational tool that allows you to manage lists of entity names in a 
library for later use  

• A filtering tool that allows you to create, edit, and save entity lists in an 
efficient manner  

• A tool for viewing data for a selected peer group 
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THE PEER GROUP MANAGER  
The Peer Group Manager window lists the peer groups in your default Peer Group 
Library. From it, you can create new peer groups, open existing peer groups, and edit 
or delete unused peer groups.  

The toolbar on the Peer Group Manager window allows you to open your saved peer 
groups, then reuse and revise the data they contain. 

The New Peer Group button allows you to create a new peer group by selecting 
from a list of available entities.  

The Edit Peer Group button allows you to add or delete entities from a previously 
created peer group.  

The Delete Peer Group button allows you to permanently delete a peer group from 
the peer group library.  

The Data Navigator for Selected Peer Group button launches the Data Navigator 
with all available information for that peer group.  

The RDI Doc Retriever button launches your web browser to connect to RDI Online 
and extract data for the selected peer group.  

The Create Peer Group from POWERmap Selection button allows you to use data 
from POWERmap to create a peer group that can be used in COALdat. This button 
only appears if you have POWERmap (or POWERmap in MapInfo Professional) on 
your system. For more information on POWERmap, contact an RDI sales 
representative.  

The New Peer Group Library button allows you to create a new file to hold saved 
peer groups.  

The Open Peer Group Library button allows you to open existing libraries 
containing previously saved peer groups.  

The Save to Existing Peer Group Library button allows you to save a selected peer 
group to another peer group library. 
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Creating a New Peer Group Library 
Before creating a new peer group, you will need to set up a library in which to save 
the new group.  

1. Click the Peer Group Manager button on the main toolbar. 

2. Click the New Peer Group Library button on the toolbar in the Peer Group 
Manager window.  

3. The Save As window appears. Enter a file name for the library. For this 
example, call the new library Sample Peer Groups.pgd.  

4. Click OK to accept this new library name and return to the Peer Group Manager 
window. Notice the name of the peer group library in the bar at the bottom of the 
Peer Group Manager window. 

NOTE: You can share peer groups with other users by creating a peer group library on a 
shared network drive.  

 

Creating a Peer Group from the Peer Group Manager 
This example will create a peer group that contains all mines or coal sources 
controlled by the Apple Coal Company and Arch Coal, Inc.  

1. Click the New Peer Group button on the Peer Group Manager toolbar. 
The Adding New Peer Group window appears: 
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2. On the left side of this window, select a Category from the drop-down list. In 
this case, select Mine Controlling Company to bring up a list of all the 
controlling companies in the database.  

3. Scroll down the list of available items and add Apple Coal Co. and Arch Coal, 
Inc. to the list on the right by double-clicking them or highlighting them and 
clicking Add. 
 
You can also remove selected entries by highlighting them and clicking Remove, 
or clear the selected list by clicking Clear All. 

 

4. Next, to view mines and coal sources controlled by Apple Coal Company and 
Arch Coal, Inc., choose Mine/Coal Source from the Category drop-down menu 
on the right side of the window.  

5. Enter a name for your new peer group. The Name field is limited to 30 
characters, so call this peer group Apple Arch Coal Mines. Click Save, and the 
new peer group will be saved into the library that is currently active. You return 
to the Peer Group Manager window. 
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Note that the location of the peer group library appears at the bottom of the Peer 
Group Manager window.  

Creating a Peer Group from the Entity Navigator 
You can create peer groups from any list of entities, including the Entity Navigator.  

In the following example, creating a peer group through the Entity Relationships 
feature allows you to view data for all electric plants held by Cinergy Corp. 

1. Close all windows from the previous example. 

2. Open the Entity Navigator from the View menu. 

3. On the Entity Navigator window, select Holding Co. in the list on the left by 
clicking its option button. 

4. Find the Cinergy Corp. in the entity list. You can either scroll through the list of 
entity names, or use the following quick search function: 

a. Type “Cin” in the header bar of the Name column. 

b. Click the Enter key to start the search. The Cinergy Corp. is the first item 
on the list to contain your keyword, so COALdat highlights it for you. 
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5. Click the Entity Relationships button. 

6. When the Entity Relationships window appears, change the entity type to 
Electric Plant to display all electric plants associated with Cinergy Corp. 

7. Click the Create Peer Group from Grid button on the main toolbar. The 

Adding New Peer Group window appears. 

8. On the Adding New Peer Group window, the list on the left includes all electric 
plants in the database. The list on the right contains only the electric plants that 
make up Cinergy Corp. 
 
You can use click Add or Remove (between the available and selected items 
lists) to make changes to the peer group list. For this example, however, leave 
the default list intact. 

9. In the Name panel, enter a name for the peer group. The field is limited to 30 
characters; call it Cinergy Corp Electric Plants. 
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10. Save the peer group by clicking Save. This peer group will be automatically 
saved into your default library. 

NOTE:�If you have not yet created a Default Peer Group Library, you will be prompted 
to do so. For details, please refer to the Creating a New Peer Group Library section of 
this chapter. 

Creating a Peer Group from a Data Grid 
You can also create a peer group from almost any COALdat data grid. 

1. Close all windows from the previous example. 

2. Click the Open Query button on the main toolbar. On the Open Query 
window, navigate to the folder in which you saved the 4 Corners Prod 95 & 97 
query that you created previously and open it. 

3. COALdat cannot create a peer group without a designated ID field. So move to 
the Items tab and add the RDI Mine Controlling Company ID item.  

4. Run the Query by clicking the Process button. 
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5. When the data results grid appears, click the Create Peer Group from Grid 
button on the Grid Tools toolbar.  

NOTE: If you have conflicting levels of information in your query, a message window 
informs you which field will be used in creating the peer group.  In general, COALdat 
will default to the higher entity level. 

6. In this example, the Mine Operating Company field is in conflict with the Mine 
Controlling Company field. Click OK on this message window to have 
COALdat decide which of the two fields to use. 

The Adding New Peer Group window appears. All of the companies that 
resulted from the query have been preselected on the peer group list. 

7. Next, view a list of mines associated with the selected companies by changing the 
Category drop-down list (under the Name panel on the right side of this window) 
to Mine/Coal Source.  

8. Name the peer group 4 Corners Mines, and then click Save. The peer group 
will be saved into your default peer group library, and it can be accessed from 
the Peer Group Manager for use in other data sets.  



CHAPTER 9: PEER GROUP MANAGER © 2002 PLATTS, A UNIT OF THE MCGRAW-HILL COMPANIES, INC. 131 

Editing Peer Groups 
Peer group settings can be edited by using the Edit Peer Group button, which is 
available in the Peer Group Manager when a peer group has been selected.  

The Editing Peer Group window is very similar to the Adding Peer Group window 
and functions in the same manner. You can use it to add or remove entities from your 
peer group. 

To save your changes in place of the original file, click Save. To save changes to a new 
file, click Save As, and give the new file a name when the Save As window appears. 

Deleting Peer Groups 
The Delete Peer Group button is active in the Peer Group Manager when a peer 
group has been selected. It allows you to remove peer groups that are no longer in use.  

On the Peer Group Manager window, highlight the peer group you wish to delete and 
click the Delete Peer Group button. A message window will appear, asking you to 
confirm your deletion. Click OK to confirm, and the peer group will be removed from 
your peer group library. 

You can also choose more than one peer group to delete at once by holding down the 
Ctrl key on your keyboard as you select multiple items with your mouse. 
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USING PEER GROUPS IN OTHER COALDAT COMPONENTS 
Once you have created a Peer Group, it can be used in conjunction with Profiles, 
Analyzers, and the Query Builder.  

Using Peer Groups from within the Query Builder 
You can use a previously created peer group on the Filter tab of the Query Builder.  

1. Launch a new Query by clicking the Create New Query button on the main 
toolbar. 

2. On the Data Sets tab, select Coal Transactions. 

3. On the Items tab, select Mine Controlling Company, Mine/Coal Source, Date 
(YYYYMM), and Del ¢/mmBtu. 
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4. On the Filter tab, click Add to begin a new filter, then use the drop-down menu 
next to the Item field and choose Mine/Coal Source Peer Group. For this 
example, use begins with, the default Operator. 

5. Click the ? button next to the Example field. The Example Options window 
appears.  

6. Click Choose From List to bring up the list of available peer groups.  The peer 
groups listed will be all those that contain information that can be accessed 
through the data set you designated on the Query Builder window.  

7. Double-click the Apple Arch Coal Mines peer group to populate the Example 
field in the Query Builder. Then click OK in the Example Options window to 
return to the Filters tab. 

8. You can process the query by clicking the Process button on the Query Builder 
window. When you are finished, close the query without saving. 
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Using Peer Groups through the Data Navigator 
The Peer Group Manager allows you to access the Data Navigator for a single peer 
group. When opened from the Peer Group Manager, the Data Navigator will include 
only the software components that apply to the peer group subject.  

In the following example, you will use a peer group in an Analyzer. 

1. Close all windows from the previous example. 

2. Launch the Peer Group Manager from the View menu on the main menu. 

3. In the Peer Group Manager window, highlight the Cinergy Corp Electric Plants 
peer group that you created earlier in this chapter.  

4. Click the Data Navigator for Selected Peer Group button on the Peer Group 
Manager toolbar (not on the main toolbar). 
 

All data sets that apply to the entities in your peer group will be available.  Note 
that the name of your peer group appears in the Data Navigator header bar. 
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5. Navigate down the information tree to Operations > Consumers > 
Consumption, Generation & Capacity > Consumption & Generation Analyzer. 

6. When the Analyzer window appears, the Filter tab is pre-set to include the 
Cinergy Corp Electric Plants peer group. 
 
You can clear the peer group by clicking the Clear All Filter Selections button, 
and the Analyzer will revert to its full data set.  

Accessing a peer group through the Data Navigator can offer the option of launching 
the Comparative Analysis tool for your peer group. When it is available, clicking the 
Comparative Analysis button on the main toolbar generates a grid that you can 
modify or graph using the Grid and Graphing Tools. 

NOTE: Because the Comparative Analysis feature must access data on all entities in a 
selected grid, using it in a very large data set may cause memory problems and can take 
time. RDI recommends that you refine your data set before using the Comparative 
Analysis tool. 
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USING PEER GROUPS IN OTHER RDI APPLICATIONS 
Not only can you use peer groups in other COALdat components, but also in other 
applications developed by RDI.  

Sharing Peer Group Libraries with other Database Applications 
For any RDI database application – COALdat, POWERdat, GASdat, BaseCase – 
you can create peer groups, save them to peer group libraries, and then share those 
libraries with any of the other applications. 

You could, for example, call up the Peer Group Manager in COALdat, and then 
use any of the peer group libraries that you created in POWERdat. By the same 
token, you could launch the Peer Group Manager in GASdat, and then switch to 
any peer group library that you created in COALdat. 

1. Close all windows from any previous examples. 

2. Click the Peer Group Manager button on the main toolbar. 

3. Click the Open Peer Group Library button on the Peer Group Manager toolbar. 
The Open Peer Group Library window appears. 

4. Click the Look in drop-down list at the top of this window, and then navigate to 
the drive and folder that holds the Peer Group Library files (.pgd) for another 
RDI database application. 
 
In the example below, the Peer Group Manager window shows the folder 
holding GASdat peer group libraries.  
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5. Click OK to accept this information. The currently open peer group library 
appears as the Library File at the bottom of the Peer Group Manager window.   

You can also see how this works by trying it in the opposite direction. Open another 
RDI database application that you may have: POWERdat, GASdat, or BaseCase. Then 
open a COALdat peer group library from within that application’s Peer Group Manager. 

Creating Peer Groups from POWERmap Selections 
If you also have the POWERmap (or POWERmap Europe) application from RDI, 
then you can select information from any map layer and create a peer group in 
COALdat from that information.  

For this example, a peer group will be created from a selection made in POWERmap.  

1. Make any selection of data in POWERmap. You could, for example, select all 
electric plants in the states of Washington and Oregon, as described in the 
POWERmap User Guide. 

2. Return to COALdat, and then click the Peer Group Manager button on the 
main toolbar. 

3. Make sure that the Sample Peer Groups library that you created previously is 
also the currently open library in COALdat. If it is not, then switch to that 
library in the manner described earlier in this chapter. 

4. Click the Create Peer Group from POWERmap Selection button on the Peer 
Group Manager toolbar. COALdat will show its progress as it builds a peer 
group from your POWERmap selection.  

5. A message window will appear telling you the number of records to be added to 
this peer group, and asking if you want to continue building it. Click Yes, and 
the Adding New Peer Group window appears. The information that appears in 
this window corresponds to the selection you made in POWERmap. 
 
From here you can make further changes to the peer group, name it, and then 
save it to the Sample Peer Groups library. 

For more information on POWERmap, please refer to the POWERmap 
documentation, or contact your RDI account manager. 
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